How hot would you run transistors

For the three and more legged things
Post Reply
brig001
Old Hand
Posts: 390
Joined: Sat Nov 13, 2010 9:56 pm
Location: Back home in Preston now

How hot would you run transistors

Post by brig001 » Fri Sep 13, 2013 11:35 pm

This is for my new amplifier, but thought it deserved a separate thread. I am using multiple ZTX450 and ZTX550 transistors (e-line package - a bit like a thin TO92). The datasheet states the maximum operating temperature as 200 deg C. I am running them at about 200mW and 90 deg C. The thermal resistance die to air is 175 deg C/W (probably allowing for some cooling by the PCB too which I don't have), but I don't know what it is die to case, so I can't calculate die temperature. What do we think? Is 90 deg C too hot?

I have already reduced to bias so now it is only class A for the first watt, the original design ran at 110 deg C :shock:

Thanks,
Brian
Last edited by brig001 on Sat Sep 14, 2013 1:52 pm, edited 1 time in total.

User avatar
Nick
Site Admin
Posts: 11362
Joined: Sun May 06, 2007 10:20 am
Location: West Yorkshire

Post by Nick » Fri Sep 13, 2013 11:52 pm

Well, 175 C/W and 200mw would put the die at only 30C above ambient. I am guess you have measured the outsides being hotter than that?

I guess it will heat up the air around the things, maybe mount them vertically with a plain in front of them to get convection to help with a chimney effect.

Or you could find some of the fluid they used to fill Cray-2's with.
Resistance isn't futile it's V / I.

User avatar
ed
retired
Posts: 3641
Joined: Thu Jun 21, 2007 4:01 pm
Location: yorkshire
Contact:

Post by ed » Sat Sep 14, 2013 8:53 am

I think I'd attempt to get that down a bit, if you have the room...

something like this?

http://www.rapidonline.com/electronic-c ... ink-77178/
There's nowhere you can be that isn't where you're meant to be

brig001
Old Hand
Posts: 390
Joined: Sat Nov 13, 2010 9:56 pm
Location: Back home in Preston now

Post by brig001 » Sat Sep 14, 2013 12:21 pm

Thanks Nick and Ed. The mistake I made is to put 80 of them in close proximity, so that's a total of 16 Watts in quite a small space. The ambient around the transistors is 55 deg C, so it sounds like the die and the case are at a similar temperature, so I'm not going to worry about it. I think I'll need some holes in the lid before I put it on though.

Brian

User avatar
pre65
Amstrad Tower of Power
Posts: 17316
Joined: Wed Aug 22, 2007 11:13 pm
Location: North Essex

Post by pre65 » Sat Sep 14, 2013 12:40 pm

brig001 wrote: The mistake I made is to put 80 of them in close proximity,
Brian
80 ? :o
Life is what happens to you while you're busy making other plans. John Lennon

G-Popz THE easy listening connoisseur. (Philip)

brig001
Old Hand
Posts: 390
Joined: Sat Nov 13, 2010 9:56 pm
Location: Back home in Preston now

Post by brig001 » Sat Sep 14, 2013 1:24 pm

I thought I could build a class A amp without heatsinks - optimistic with hindsight, but I like the sound, so I'm going to persevere. Instead of one or two large output transistors, I used 20 small ones per amplifier; 10 npn and 10 pnp. Active crossover means 4 amplifiers, so 80 transistors in total. Should have spread them out a bit, or got more space to fit them in. Like every design, it evolves around a set of compromises, and keeping the size down to reduce loop area for noise pickup was one of the considerations. It worked too. My last amplifier picked up noise from a neighbour, or more likely the lift, this one is totally silent. Small loop areas, ground plane, decoupling everywhere and a mains filter sorted it.

Brian

Post Reply