Search found 28 matches

by Wolfgang Felber
Tue Mar 19, 2019 5:21 am
Forum: General Vinyl
Topic: Technics Sp10 Woes
Replies: 33
Views: 4716

Re: Technics Sp10 Woes

HI Nick, I still have 32.5 volts, the reason I say that is the plunger for the brake still works fine, you can hear the clicking every time you press the on/off button. All of the voltages appear to be OK. To be sure I will measure them again tonight. Thank you for being patient.
by Wolfgang Felber
Mon Mar 18, 2019 10:33 pm
Forum: General Vinyl
Topic: Technics Sp10 Woes
Replies: 33
Views: 4716

Re: Technics Sp10 Woes

Yes I do, it is etched into my brain. I used the ground probe of the scope onto C1 and the main probe onto C2 of the drive board. I was trying to measure the waveform of the 50K oscillator circuit. AS soon as I did that, it blew a fuse and that was it. I feel like a complete fool.
by Wolfgang Felber
Mon Mar 18, 2019 5:02 am
Forum: General Vinyl
Topic: Technics Sp10 Woes
Replies: 33
Views: 4716

Re: Technics Sp10 Woes

Hi Nick, I have just about completed testing all of the transistor and diodes. I will send you the list. I am also taking measurement of all of the IC chips from each pinout. I have also got a full compliment of transistors and IC's to replace anything that is faulty. I am ready to go but not sure w...
by Wolfgang Felber
Sun Mar 17, 2019 11:29 am
Forum: General Vinyl
Topic: Technics Sp10 Woes
Replies: 33
Views: 4716

Re: Technics Sp10 Woes

Hi Nick, I worked out how to bring the SP10MK2 to original format. The ABC mod was just for the cueing of the deck. It is back to original. Now I am still trying to get it going. I replaced all the IC chips but that made no difference, the driver transistors are still getting very hot and there is n...
by Wolfgang Felber
Wed Mar 06, 2019 10:25 pm
Forum: General Vinyl
Topic: SP10 Troubles
Replies: 108
Views: 21165

Re: SP10 Troubles

Hi all, still trying to get this thing going. I am trying to follow the flow chart to find out where the problem is, I got to the point where I have to check the voltage at P3, at this point, I am only getting 4.6 millivolt instead of 0.7 of a volt. It then asks for you to check IC 1 voltages and th...
by Wolfgang Felber
Sun Jan 20, 2019 10:29 pm
Forum: General Vinyl
Topic: Technics Sp10 Woes
Replies: 33
Views: 4716

Re: Technics Sp10 Woes

Hi Nick, I certainly did, and I have spares of the chips, so I will start there. I checked the Crystal oscillator last night and that seems to work OK 3.579 mega hertz. How do I test the other oscillator circuit? the 50K Hertz circuit using T1 and Tr28. Just out of left field, can one return the SP1...
by Wolfgang Felber
Sun Jan 20, 2019 11:45 am
Forum: General Vinyl
Topic: Technics Sp10 Woes
Replies: 33
Views: 4716

Re: Technics Sp10 Woes

Hi Nick, how do I test the motor to make sure I have'nt destroyed it? I did put the multimeter on ohms and measured the motor from AC to A1, AC to A2 and AC to A3 they all read 14.5 ohms across them all, is that OK or have I destroyed the motor. If that is OK, then I can sigh with relief and continu...
by Wolfgang Felber
Fri Jan 18, 2019 11:55 pm
Forum: General Vinyl
Topic: Technics Sp10 Woes
Replies: 33
Views: 4716

Re: Technics Sp10 Woes

Hi Nick, I dont know if you read my last post, but I have had a massive fail, tried testing the 50k herz oscillator circuit and something went pop. blew the 32.5 volt fuse and all I get now is the solenoid for the brake clicking. Nothing else apart from the main driver transistors getting real hot. ...
by Wolfgang Felber
Tue Jan 08, 2019 3:53 am
Forum: General Vinyl
Topic: SP10 Troubles
Replies: 108
Views: 21165

Re: SP10 Troubles

Hello to all SP10MK2 owners, I finally got mine running but had problems locking onto speed, so in my haste I tested the oscillator using C1 and C2 on the drive board, bang, 32 volt fuse popped, replaced fuse and all I get is the clicking of the brake solenoid. Platter doesnt spin, I have put some o...
by Wolfgang Felber
Tue Dec 11, 2018 1:10 pm
Forum: General Vinyl
Topic: SP10 Troubles
Replies: 108
Views: 21165

Re: SP10 Troubles

Hi Nick, the SP10 Mk2 that I have has been modified by the ABC in OZ. I will attach some more photos.
by Wolfgang Felber
Sun Dec 09, 2018 11:12 am
Forum: General Vinyl
Topic: SP10 Troubles
Replies: 108
Views: 21165

Re: SP10 Troubles

Hi Nick, will try sending a couple of photos.
by Wolfgang Felber
Sun Dec 09, 2018 6:32 am
Forum: General Vinyl
Topic: SP10 Troubles
Replies: 108
Views: 21165

Re: SP10 Troubles

Hi nic thank you for taking pity on an old fool. I would like to send you an image but every time I drag the image accross , it tells me the file size is too large, I tried zipping but that didnt work either. Can you tell me what size file I can send

Regards
Wolfgang
by Wolfgang Felber
Thu Nov 29, 2018 11:33 pm
Forum: General Vinyl
Topic: SP10 Troubles
Replies: 108
Views: 21165

Re: SP10 Troubles

Hi Nick, tried a 1.1K resistor in parallel with the 4.7k, unfortunately it didnt make any difference. I dont know if I mentioned it before but I am a Plumber not an electronics engineer. I have been struggling to get some of these waveforms that are in the service manual. I have a pretty good knowle...
by Wolfgang Felber
Tue Nov 27, 2018 5:44 am
Forum: General Vinyl
Topic: SP10 Troubles
Replies: 108
Views: 21165

Re: SP10 Troubles

Just to be clear, I am looking at the logic circuit Schematic and it it resistor R261 47k which is connected to TR220. Correct.

Regards Wolfgang
by Wolfgang Felber
Mon Nov 26, 2018 10:16 pm
Forum: General Vinyl
Topic: SP10 Troubles
Replies: 108
Views: 21165

Re: SP10 Troubles

Hi Nick, will try that tonight, something I did notice last night wast that when set to 33 or 45 the strobe was flickering slightly but when set on 78, no flickering, weird.I also noticed that when the power supply voltage is raised to 32.5 volts the platter slows down and when the voltage goes lowe...